Degraded performance with Broadsign Control Administrator

Incident Report for Broadsign Platform

Resolved

This incident has been resolved, and the operations are back to normal.
The login for BCA-Broadsign Control Administrator no longer times out.
Posted Oct 16, 2025 - 08:47 EDT

Identified

Some delays and/or timeouts are occurring with Broadsign Control Administrator. Our team has identified the issue and is currently working on a resolution.
Posted Oct 16, 2025 - 05:15 EDT
This incident affected: Content Management System (Broadsign Control) (Admin Service).