Broadsign Control Administrator Login

Incident Report for Broadsign Platform

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 19:51 EDT

Investigating

Dear Broadsign customer,

We are currently experiencing issues with the Broadsign Control Administrator login. Our engineering team is actively investigating the problem to restore service as quickly as possible.
Impact: Customers are currently unable to log into Broadsign Control Administrator. Please note that this outage does not affect player delivery.
Posted Apr 28, 2026 - 19:16 EDT
This incident affected: Content Management System (Broadsign Control) (Admin Service).