The Place Exchange website is down

Incident Report for Broadsign Platform

Resolved

The incident is resolved now. The Place Exchange website is back up and running now.
Posted Jul 28, 2026 - 10:04 EDT

Investigating

The Place Exchange website is down. We are currently investigating the issue.
Posted Jul 28, 2026 - 07:42 EDT
This incident affected: Programmatic Supply-Side Platform (Place Exchange) (Website).